03
Mrz
08

Installation von Visual Studio 2008 Team Foundation Server unter Windows Server 2008

Am Dienstag (19.02.2008) und Mittwoch (20.02.2008) war ich zum Launch-Event von Visual Studio 2008 & Co. in Frankfurt. Dort habe ich mir bei der Vorträgen von Christian Binder und Marcus Alt Informationen zu Team Foundation Server geholt. Die Vorträge haben mich begeistert, da ich bisher ausschließlich mit Subversion und OnTime gearbeitet habe!

Als Mitbringsel von der Veranstaltung habe ich Visual Studio 2008 Standard, Windows Server 2008, sowie Visual Studio 2008 Team Foundation Server und MS SQL Server 2008 mit Heim genommen. Als ich die Verpackung aufmachte, musste ich feststellen, dass MS SQL Server 2008 noch nicht fertig ist und man mir stattdessen MS SQL Server 2005 und MS SQL Server 2008 CTP mitgegeben hat.

Voller Vorfreude habe ich dann auf meiner virtuellen Maschine Windows Server 2008 installiert. Das funktioniert echt prima! OK, dann TFS-CD rein ins Laufwerk und los geht’s! Danach folgte ich den Anweisungen des TFS Install Guide, den ich extra aus dem Internet aktualisiert herunter geladen hatte.

In dem Abschnitt „Prerequisite Installation“ stand „Before you deploy Team Foundation Server on a single server that is running Windows Server 2008, you must install IIS 7.0.“. Ok, also wieder in den Server Manager und folgende Rollen aktiviert:

  • ASP.NET
  • HTTP Redirections
  • IIS 6.0 Compatibility
  • Default options
  • Windows Authentication

Gut, danach steht in der Checklist, dass ich MS SQL Server 2005 auf Windows 2008 installieren soll. „Kein Problem“, dachte ich mir – TFS CD raus – SQL Server 2005-CD rein ins Laufwerk und Installation starten. Schon wieder eine Meldung:

Mit fehlte also zusätzlich noch Microsoft SQL Server 2005 Service Pack 2! Warum wird sowas dem Paket nicht beigelegt? Also bin ich den Hinweisen des Kompatibilitätsassistenten gefolgt und habe von der Microsoft Homepage das Service Pack 2 heruntergeladen (282MB) und nach meiner Installation von CD noch das Service Pack drauf gemacht.

Jetzt endlich sollte es losgehen! Wieder TFS-CD eingelegt und Setup gestartet. Plötzlich geht es nicht mehr weiter:

Ich habe keine Windows SharePoint Services Seite!! Woher bekomme ich diese nun? Ich erinnerte mich, dass beim Autostart der CD etwas von SharePoint Erweiterungen stand:

Also versuche ich es mal mit diesem Installer. Doch dieser bricht auch ab mit folgender Fehlermeldung:

Und abschließend stürzt das Setup dafür komplett ab:

Na toll! Woher bekomme ich nun Windows SharePoint Services 3.0? Warum ist das nicht mit auf der CD? Muss ich mir extra SharePoint anschaffen, nur um diesen TFS zu installieren? Das Handbuch half mir nicht wirklich weiter .. also musste google ran! Prompt wurde ich fündig: http://geekswithblogs.net/etiennetremblay/archive/2008/02/05/windows-2008–tfs-2008-it-works-but.aspx

Dort hatte jemand die gleichen Erfahrungen gemacht, wie ich. Allerdings bot er mir auch einen Link an, wo ich Windows SharePoint Services 3.0 (104MB) direkt von der Microsoft Homepage herunterladen konnte. Schon wenige Minuten später konnte die Installation los gehen:

[Update 01.03.2008]

Bei der Installation ist es wichtig, bei der „Erweiterten Installation“ den Servertyp von „Eigenständig“ auf „Web-Front-End Computer“ umzustellen:

Nach beendeter Installation kann die Konfiguration beginnen:

[Update 28.02.2008]

Ich führe nun die Kommandozeilen-Befehle aus, die im TFSInstall.chm stehen:

stsadm.exe -o extendvs -exclusivelyusentlm -url http://WSSServerName:Port -ownerlogin DomainUserName -owneremail „admin@localhost“ -sitetemplate sts -description „Description“

Das Ergebnis der Aktion sieht man hier:

„Die von Ihnen ausgewählte IIS-Website wird von SharePoint verwendet. Sie müssen einen anderen Port oder Hostnamen auswählen.“

Hä? Ich hab doch extra alles so befolgt, wie es in der Hilfe stand!?

Ich werde dann mal den Tipp von Peter (siehe Comments) befolgen und mein „Sharepoint 80“ löschen und dann die Kommandozeilen-Befehle neu ausführen. Leider hat das auch nix gebracht …

[Update 03.03.2008]

Nachdem mir Peter den entscheidenden Tipp gegeben hat, dass ich nicht denselben Port verwenden darf, wie meine Sharepoint-Administration (sorry 😦 ), funktioniert alles wie es soll:

Nun schalte ich noch die Logins für den extra eingerichteten TFSSetup-User frei:

stsadm.exe -o siteowner -url http://tfs2k8:80 -secondarylogin TFSSetup

Für alle die es interessiert, wo dann die Seite mit stsadm.exe angelegt wird:

image

Dann kann’s ja mit der Installation losgehen …

[Update 04.03.2008]

Ich habe nun die Schritte bis zur Eingabe des Sharepoint Servers durchgeführt. Nun erhalte ich allerdings folgende Meldung:

image

Meine Einstellungen für Windows SharePoint Services sind die Folgenden:

image

Hier versuche ich es mal mit dem Tipp von Thomas und Peter (siehe Comments) und gebe statt http://TFS2k8:80/Sites –> http://TFS2k8:80/Websites an, da ich ebenfalls über die deutsche Version von Team Foundation Server verfüge:

image

Erst hat er rumgezickt .. aber es dann doch mit diesen Einstellungen übernommen!

Also ganz wichtig bei der deutschen Version von Team Foundation Server:

Statt http://SERVERNAME:PORT/Sites –> http://SERVERNAME:PORT/Websites

image

Und das ist die „Belohnung“ für die Mühen 🙂

image

Die Installation ist endlich abgeschlossen.

Zusammenfassung der wichtigsten Links soweit

Microsoft SQL Server 2005 Service Pack 2: http://www.microsoft.com/downloads/details.aspx?FamilyID=d07219b2-1e23-49c8-8f0c-63fa18f26d3a&DisplayLang=en

Windows SharePoint Services 3.0 with Service Pack 1: http://www.microsoft.com/downloads/details.aspx?FamilyId=EF93E453-75F1-45DF-8C6F-4565E8549C2A&displaylang=en

Advertisements

18 Responses to “Installation von Visual Studio 2008 Team Foundation Server unter Windows Server 2008”


  1. 1 Thomas
    27. Februar 2008 um 23:12

    Hallo,

    mich würde interessieren, wie du nach der Installation von WSS 3.0 SP1 weiter vorgegangen bist.

    Ich habe versucht, der Anleitung von MS zu folgen und führte die Kommandos auf der Befehlszeile aus. Leider komme ich bei der Installation von TFS nicht voran, sondern bekomme eine Fehlermeldung.

    Wenn du weiter kommen würdest als ich, wäre ich für eine Antwort bzw. einen weiteren Blog-Eintrag dankbar.

    MfG

    Thomas

  2. 28. Februar 2008 um 10:40

    Hallo,

    wir haben in den letzten auch einige Nerven gelassen bei dem Versuch den TFS2008 zu installieren. Ergebnis s.o.
    Heute konnten wir den Installer dann doch dazu bewegen die frischen WSS 3.0 zu verwenden.
    Wir haben die WSS 3.0SP1 nach Anleitung installiert und dann auch noch die Schritte auf der Kommandozeile durchgeführt. Das ging schief, weil WSS bei der Installation schon eine „Sharepoint 80“ Web application angelegt hatte. Die haben wir gelöscht und dann nochmal die stsadm-Befehle mit anschliessendem iisreset durchlaufen lassen. Achtung:Das Kommandozeilenfenster muss als Administrator gestartet werden!
    Das hat soweit funktioniert.
    Bei URL-Angabe im Installer darf man für die default site keinen Port angeben. Bei uns hat es mit http://servername/sites funktioniert.
    Nun läuft die Installation erstmal weiter.
    Bei so einem Installationsvorgang kann man wirklich nur den Kopf schütteln.

    Grüße,
    Peter

  3. 3 Thomas
    28. Februar 2008 um 11:06

    Hallo Peter,

    ihr habt bei dem stsadm-aufruf als server http://servername/Sites angegeben und nicht http://servername ? wenn das geht bin ich erleichtert und werde es nochmal probieren.

    Ich habe schon mit Christian Binder von MS gesprochen, da ich eigentlich die CTP vom SQL2008 verwenden wollte. Das Problem ist halt, dass der TFS vor dem Windows Server 2008 fertig war. Die werden aber einiges nochmal fixen, hat er mir gestern am Telefon gesagt.

  4. 4 Thomas
    3. März 2008 um 08:29

    Hallo,

    ich habe es mittlerweile hinbekommen.

    ACHTUNG DEUTSCHE W2K8-INSTALLATION MIT DEUTSCHEN WSS 3.0SP1:

    – W2K8 normal installiert
    – TFS-User angelegt und Rechte vergeben(laut Anleitung)
    – SQL-Server2005 installiert (laut Anleitung)
    – WSS 3.0 SP1 installiert
    – die 19 Schritte für die WSS-Installation/Konfiguration durchgemacht (laut Anleitung)
    – TFS installiert.
    – bei Angabe der Sharepoint-Seiten folgendes eingetragen:
    Admin: http://SERVERNAME:17012
    User: http://SERVERNAME/Websites

    das mit Websites habe ich durch Zufall gefunden, weil ich immer eine Fehlermeldung bekam, die mir sagte das Sites nicht in der Standardseite ist (oder so ähnlich)

    Danach funktionierte alles einwandfrei.

  5. 3. März 2008 um 20:23

    Hallo Thomas, hallo Peter,
    vielen Dank für eure Kommentare.

    Ich werde demnächst die vollständige Installation posten. Hab momentan recht viel um die Ohren.

    Vielen Dank nochmal für eure Tipps!

    Beste Grüße
    Ralf

  6. 6 Marc
    5. März 2008 um 12:03

    Hallo an alle fleißigen „Installierer“,
    Danke für die Mühe und das Posten hier im Blog. Habe seit Tagen versucht diesen vermaledeiten TFS 2008 zum laufen zu bringen um endlich damit arbeiten zu können (erst als Update auf TFS 2005, dann auf WS2008). Letztendlich scheiterte es an http://SERVERNAME/Websites

    Gruß
    Marc

  7. 7 Alexander
    20. März 2008 um 13:57

    “Die von Ihnen ausgewählte IIS-Website wird von SharePoint verwendet. Sie müssen einen anderen Port oder Hostnamen auswählen.”

    Hatte das Problem auch bei der Installation
    eines Microsoft Search Server 2008 Express.
    Lösung: Man muss die Standard Webanwendung
    (SharePoint – 80) per Zentraladministration
    entfernen.
    1. Click Start, point to All Programs, point to Administrative Tools, and
    then click SharePoint 3.0 Central Administration.
    2. On the Application Management tab, in SharePoint Web Application
    Management, click Delete Web Application.
    3. On the Delete Web Application page, complete the following:
    1) In Web Application, from the drop-down menu, click Change Web
    Application. On the Select Web Application page, select the Windows
    SharePoint Services 3.0 default Web site (http://ServerName).
    Note: Make sure that you delete the default Web site (http://ServerName)
    and not the site that you just created in the preceding step.
    2) In Delete options, delete the content databases and the IIS Web sites.
    3) Click Delete.
    4) In the warning message box, click Yes.
    4. Wait for the Application Management tab to appear, and then close the
    Windows SharePoint Services Central Administration site.

    Danach lief die Installation durch.

  8. 8 Ewald Heck
    1. April 2008 um 15:54

    Super Tip mit den „Websites“ statt „Sites“!
    Ich habe an dieser Stelle Stunden verbracht, nun geht es endlich!

    Vielen Dank!

  9. 9 Torture
    4. Juli 2008 um 14:49

    mich würde interessieren, wie du die Reporting Services auf dem Server 2008 installiert hast, der TFS braucht diese doch, oder ?

  10. 10 Ben
    20. Juli 2008 um 15:43

    Coole Anleitung, herzlichen Dank!
    Damit hab’s ich endlich auch geschafft, den TFS mal zu installieren. Bin zuvor auch jedesmal an der Sites/Websites-Falle gescheitert ;o)

    Kleine Info am Rande: ich hatte gehofft, der TFS würde anstatt dem SQL Server 2005 auch schon mit dem RC des 2008ers funktionieren. Den Versuch könnt Ihr Euch sparen – wird vom TFS-Setup nicht als unterstützte Version anerkannt :/

  11. 11 Thomas S
    8. August 2008 um 06:48

    Puh wollte den TFS auf die schnelle installieren und dann sind solche Stolperfallen drin. Da frage ich mich immer wieder, was sich die Typen bei Microsoft bei sowas gedacht haben? Naja egal er wird nun gerade installiert, nachdem ich auch über das Problem mit Sites-Websites gestolpert bin (und zum Glück hier die Lösung gefunden habe. Danke!

  12. 12 Thomas S
    8. August 2008 um 07:02

    Ich krieg noch echt Zustände mit dem blöden Setup, jetzt kommt hinten raus noch die Meldung dass er auf den Reporting Server nicht zugreifen kann, na super :-/ für den Blödsinn das Teil zu installieren verschwende ich nun schon einen ganzen Arbeitstag, das is ja nicht normal

  13. 2. September 2008 um 22:04

    hallo, vielen dank für diese anleitung.
    vielleicht wäre folgendes noch zu erwähnen:
    – bei dem konsolen-befehl ist das anlegen der website unbedingt port 80 zu verwenden (ich hatte es mit einem anderen probiert und das ging nicht)
    – bei der zentralverwaltungsurl ist die von sharepoint gemeint (das war zumind. für mich nicht gleich so klar)

    Ronald

  14. 14 Heisenberg
    24. Oktober 2008 um 11:21

    Ersteinmal: Ganz Herzlichen Dank !!

    Ich habe es direkt mit SQL2k8 probiert – so weit so schlecht

    Ich bekomme bei der Installation des TFS Servers (Sharepoint läuft schon und zeigt ne schöne bunte Seite) die Fehlermeldung, dass mein Server als Domänen Controller eingerichtet ist.
    Ist das Unsinn oder gehen AD & TFS wirklich nicht zusammen ?
    Danke & Gruss
    Heisenberg

  15. 15 DerHilflose
    21. Dezember 2009 um 17:21

    Hallo, erst mal vielen Dank für die detailierte Anleitung.

    Trotzdem verzweifle ich im Moment an der Installation.
    Mein Vorhaben:
    Installation von TFS 2008 WG auf Win2k8 Server mit MSSQL Server 2008 Standard.

    Die Installtion bis einschließlich SQL2008 mit allen Tools und WSS3.0, beides mit allen SP und Updates, klappte gut.

    ABER:
    Bei der Installation behauptet TFS WG trotz vorschriftsmäßig hergestellter „Merge-Version“, dass die Installierte SQL Version (2008 Standard) keine kompatible Version sei.

    Irgendwelche Ideen?

    Danke&Gruss

    DerHilflose

  16. 16 TFSAnfänger
    4. Januar 2010 um 11:59

    Hallo du Hilfloser… 😉
    Ich hatte das Problem mit SQL-Server 2008 ebenfalls.
    Hier gibt es einen Workaround in einem MS-Blog. Ich hoffe, das hilft Dir weiter.

    http://blogs.msdn.com/rextang/archive/2009/05/19/9625393.aspx

    Gruss

  17. 17 DerHilflose
    4. Januar 2010 um 13:37

    Hallo,

    danke für die Hilfe.

    Ich war bereits in die Richtung am Suchen, habe den SQL überwacht und versucht rauszufinden wo es schiefgeht.

    Mit dem Workaround scheint es aber zu klappen.

    Gruss

    DerHilflose

  18. 18 fabich
    1. April 2010 um 19:18

    hey

    nur so als kleiner tipp von mir:
    Windows Server 2008 x64 und Team Foundation Server Workgroup Edition (x86 and x64 WoW) laufen NICHT zusammen.

    Das x64 Wow scheint sich auf den SQL Server zu beziehen.

    gruss

    fabich


Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s


Blog Stats

  • 194,056 hits

%d Bloggern gefällt das: